The Mjolnir 2 thread

Discussion in 'Amplifiers and Combo (DAC/Amp) Units' started by maxedfx, Oct 11, 2015.

  1. murphythecat

    murphythecat Facebook Friend

    Joined:
    Apr 4, 2016
    Likes Received:
    69
    Dislikes Received:
    5
    Trophy Points:
    28
    very curious if someone compared the ifi pro ican to the Mjolnir 2 especially with the hd800...
     

  2. ufospls2

    ufospls2 Rando

    Joined:
    Jan 10, 2017
    Likes Received:
    17
    Dislikes Received:
    0
    Trophy Points:
    3
    Location:
    Canada
    murphythecat likes this.
  3. a44100Hz

    a44100Hz Friend

    Friend
    Joined:
    Jan 1, 2016
    Likes Received:
    391
    Dislikes Received:
    1
    Trophy Points:
    63
    Location:
    US East
  4. ufospls2

    ufospls2 Rando

    Joined:
    Jan 10, 2017
    Likes Received:
    17
    Dislikes Received:
    0
    Trophy Points:
    3
    Location:
    Canada

    Lack of detail, muffled sounding, overly warm (and I am a warm and dark type of person I think.) I was really bummed by the sound, as I went in thinking it was a potential purchase after all the Schiit praise I've read/heard. The iFi was leaps and bounds better. But again, that Mjolnir 2 was totally stock, so it may be completely different with upgraded tubes, or the LISST solid state tubes, I don't know.
     
  5. murphythecat

    murphythecat Facebook Friend

    Joined:
    Apr 4, 2016
    Likes Received:
    69
    Dislikes Received:
    5
    Trophy Points:
    28
    very helpful. what headphone did you try with mjolnir and ipro?
     
  6. ufospls2

    ufospls2 Rando

    Joined:
    Jan 10, 2017
    Likes Received:
    17
    Dislikes Received:
    0
    Trophy Points:
    3
    Location:
    Canada
    Focal Utopia and Abyss.
     
  7. murphythecat

    murphythecat Facebook Friend

    Joined:
    Apr 4, 2016
    Likes Received:
    69
    Dislikes Received:
    5
    Trophy Points:
    28
    did you find the ipro a worthy upgrade from the Ican se?
     
  8. ufospls2

    ufospls2 Rando

    Joined:
    Jan 10, 2017
    Likes Received:
    17
    Dislikes Received:
    0
    Trophy Points:
    3
    Location:
    Canada
    Well, its a tremendous price difference, so whether or not it is worth it really depends on how much you feel comfortable spending. The Pro has more features, two tube modes etc..It is also much more powerful, 14w (if I remember correctly) vs 4w. If you are going to be using difficult to drive headphones, ESPECIALLY if you want to use the bass boost feature, this is definitely something to consider as you might run into clipping issues at high volumes with the SE. However, the SE is transportable and small, which is great if you are going to be travelling, or just want something that does not take up much space. If I was going to get a desktop only amp, had space, and had the coin, I would go for the Pro. This is the Mjolnir 2 thread though, so it might be better if you have other questions to ask them in the iFi thread :)
     
  9. neogeosnk

    neogeosnk Almost "Made"

    Contributor
    Joined:
    Sep 28, 2015
    Likes Received:
    104
    Dislikes Received:
    0
    Trophy Points:
    43
    Location:
    Los Angeles, CA
    These are my primary tubes. Don't have time to tube roll but these calm down the treble and bring up the vocals which is my preference. Also got Chinese adapter and rolled my own cheap-o version of the iFi Nos 5670 and it sounded nearly identical. You may want to try that first.
     
  10. a44100Hz

    a44100Hz Friend

    Friend
    Joined:
    Jan 1, 2016
    Likes Received:
    391
    Dislikes Received:
    1
    Trophy Points:
    63
    Location:
    US East
    I wouldn't describe my Valhalla 2 or Lyr 2 as sounding like how you described the Mjo 2, and the Mjo 2 should not be losing to the Lyr 2 in detail or clarity. Maybe something funky was going on with that particular chain.
     
    Turdski likes this.
  11. hifi01170

    hifi01170 Facebook Friend

    Joined:
    Oct 12, 2015
    Likes Received:
    25
    Dislikes Received:
    0
    Trophy Points:
    28
    hi guys, @schiit ,

    just tried swapping the stock tubes with the LISST tubes and suddenly, on the left channel I'm hearing a buzzing sound... and music only plays on the right channel...
    Did another try with amperex tubes and same thing.... buzzing sound on the left channel and music on the right channel (with my active speakers connected via xlr as well as with the headphone out using the th-x00). Tried various sources (xlr/single ended) in vain... the problem is still there!

    Anybody can help? Just trying here before contacting the customer service in UK...

    Cheers!
     
  12. PoochZag

    PoochZag The Shadow knows - Friend

    Friend
    Joined:
    Oct 7, 2015
    Likes Received:
    791
    Dislikes Received:
    0
    Trophy Points:
    93
    Location:
    Indiana USA
    @hifi01170

    Were there any symptoms leading up to this? Did/is the amp unusually hot? Kinda sounds like what happened when my left output transformer blew, but there was a bit of scratchiness and static in the few days leading up to it, then all real sound went away in the left and it got SUPER hot. Happened with a LISST inside too, which was taken out in the process. Schiit kindly replaced that LISST for free even tho out of warranty (amp was in warranty)

    If you switch LISST or tubes left/right and its still in the left, as well as switching input cables left/right, it's probably the amp
     
  13. hifi01170

    hifi01170 Facebook Friend

    Joined:
    Oct 12, 2015
    Likes Received:
    25
    Dislikes Received:
    0
    Trophy Points:
    28
    thx for your inputs @PoochZag !
    indeed yesterday i was hearing some weird "static" as you put it. then today i replaced the stock tubes with the lisst and buzzing started on the left channel. after troubleshooting i can confirm it is not the tube(s). i fear it is the same issue as yours....
     
  14. PoochZag

    PoochZag The Shadow knows - Friend

    Friend
    Joined:
    Oct 7, 2015
    Likes Received:
    791
    Dislikes Received:
    0
    Trophy Points:
    93
    Location:
    Indiana USA
    Yeah... that sounds way too familiar unfortunately. Good luck

    They did a great and quick job with the repair, but I'm in the US so hopefully it's not too bad for you
     
  15. hifi01170

    hifi01170 Facebook Friend

    Joined:
    Oct 12, 2015
    Likes Received:
    25
    Dislikes Received:
    0
    Trophy Points:
    28
    ah man... bought it second hand from a nice guy in the UK! now have to check with the electromod how to proceed.... arffff
     
  16. neogeosnk

    neogeosnk Almost "Made"

    Contributor
    Joined:
    Sep 28, 2015
    Likes Received:
    104
    Dislikes Received:
    0
    Trophy Points:
    43
    Location:
    Los Angeles, CA
    I saw someone have the same problem, but they switched tubes while the amp was on. Was your amp on while switching tubes?
     
  17. hifi01170

    hifi01170 Facebook Friend

    Joined:
    Oct 12, 2015
    Likes Received:
    25
    Dislikes Received:
    0
    Trophy Points:
    28
    @neogeosnk : i switched it off before changing the tubes....
     
  18. hifi01170

    hifi01170 Facebook Friend

    Joined:
    Oct 12, 2015
    Likes Received:
    25
    Dislikes Received:
    0
    Trophy Points:
    28
    I have contacted Schiit support as well as Electromod UK. Let's see........ :(
     
  19. Neal

    Neal Acquaintance

    Contributor
    Joined:
    Mar 30, 2016
    Likes Received:
    56
    Dislikes Received:
    0
    Trophy Points:
    18
    Location:
    DC
    Were you using the single ended out of Mojo 2 or balanced?
     
  20. ufospls2

    ufospls2 Rando

    Joined:
    Jan 10, 2017
    Likes Received:
    17
    Dislikes Received:
    0
    Trophy Points:
    3
    Location:
    Canada
    Balanced.
     

Share This Page