Valhalla 2 Loaner

Discussion in 'Closed Loaners' started by sphinxvc, Aug 31, 2016.

  1. sphinxvc

    sphinxvc Gear Master (retired)

    Staff Member Friend BWC
    Joined:
    Sep 28, 2015
    Likes Received:
    3,271
    Trophy Points:
    113
  2. Colgin

    Colgin Friend

    Friend
    Joined:
    Sep 27, 2015
    Likes Received:
    626
    Trophy Points:
    93
    • Like / Agree Like / Agree x 1
    • List
  3. Colgin

    Colgin Friend

    Friend
    Joined:
    Sep 27, 2015
    Likes Received:
    626
    Trophy Points:
    93
    I went to listen to the Valhalla 2 today. Getting a buzz in left channel of my HD 600 even with volume at zero. Something must have gotten loose in the amp. I need to wait for tubes to cool down to check but can anyone tell me if this is more likely a loose RCA input in the back or a loose tube. Thanks.
     
  4. PoochZag

    PoochZag The Shadow knows - Friend

    Friend
    Joined:
    Oct 7, 2015
    Likes Received:
    1,194
    Trophy Points:
    93
    Location:
    Boston
    Maybe swap tubes left/right and then RCA left/right to narrow it down?

    If it ends up being an input tube issue (the ones that are the same with Mjo2...etc) I have many, including the schiit stocks, that I can add to the cause
     
  5. daytripper

    daytripper Friend

    Friend
    Joined:
    Dec 9, 2015
    Likes Received:
    72
    Trophy Points:
    43
    @Colgin, please send to @PoochZag. I'm bowing out of the tour. My schedule changed and I'll be out of town for a couple of weeks unfortunately. Also sent you a PM. Thanks!
     
  6. Colgin

    Colgin Friend

    Friend
    Joined:
    Sep 27, 2015
    Likes Received:
    626
    Trophy Points:
    93
  7. PoochZag

    PoochZag The Shadow knows - Friend

    Friend
    Joined:
    Oct 7, 2015
    Likes Received:
    1,194
    Trophy Points:
    93
    Location:
    Boston
    Received from @Colgin just now, everything works fine, although my desk is at maximum Schiit capacity.

    I just wanted to note there was no power cord in the box. If it got misplaced along the way I can include the one I am using with it if needed.

    I'll send this out early next week to... @velvetx ? (also thank you for loaning your amp!)

    [​IMG]
     
    • Like / Agree Like / Agree x 3
    • List
    Last edited: Oct 13, 2016
  8. batriq

    batriq Probably has made you smarter

    Friend
    Joined:
    Oct 31, 2015
    Likes Received:
    955
    Trophy Points:
    93
    It didn't have a power cord in there when I received it (I was the first one)
     
    • Like / Agree Like / Agree x 1
    • List
  9. Colgin

    Colgin Friend

    Friend
    Joined:
    Sep 27, 2015
    Likes Received:
    626
    Trophy Points:
    93
    Yeah. No power cord came with it.
     
  10. PoochZag

    PoochZag The Shadow knows - Friend

    Friend
    Joined:
    Oct 7, 2015
    Likes Received:
    1,194
    Trophy Points:
    93
    Location:
    Boston
    This is headed back to Velvetx to complete the loaner. Is the insurance contribution just the catch all SBAF donate link? This is my first one since that system was implemented and it doesn't really say in the stickied thread
     
  11. batriq

    batriq Probably has made you smarter

    Friend
    Joined:
    Oct 31, 2015
    Likes Received:
    955
    Trophy Points:
    93
    I sent in the insurance contribution via the same donate link and mentioned in the notes it was for the Valhalla 2 loaner.
    Hope this helps!
     
    • Like / Agree Like / Agree x 2
    • List
  12. sphinxvc

    sphinxvc Gear Master (retired)

    Staff Member Friend BWC
    Joined:
    Sep 28, 2015
    Likes Received:
    3,271
    Trophy Points:
    113
    This one can be closed and archived. @velvetx, when you get a chance, just confirm you received everything in order.
     

Share This Page